Question & Answer
Question
How do you delete a record in Hang Off Table without removing the parent record in IBM Sterling Selling and Fulfillment Suite?
Cause
changeOrder call with Action= CANCEL/REMOVE/DELETE does not remove the Hang Off table record.
Answer
To remove hangoff record, pass operation="Delete" to the extn record of changeOrder input.
NOTE: Pass primary key or unique columns to identify extn record.
Sample changeOrder input xml:
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<Order EnterpriseCode="DEFAULT" OrderHeaderKey="ord_5">
<OrderLines>
<OrderLine OrderedQty="1" ReservationMandatory="N">
<Item ItemID="item1" UnitOfMeasure="EACH" Quantity="1" />
</OrderLine>
</OrderLines>
<PersonInfoShipTo Country="US" ZipCode="12345" />
<PersonInfoBillTo Country="US" ZipCode="12345" />
<Extn>
<EXTNItemActivationList>
<EXTNItemActivation Operation="Delete" ItemActKey="ord_5_key" OrderHeaderKey="ord_5" SerialNumber="6666">
<YFSOrderHeader OrderHeaderKey="ord_5"/>
</EXTNItemActivation>
</EXTNItemActivationList>
</Extn>
</Order>
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Document Information
Modified date:
16 June 2018
UID
swg21984340