IBM Support

findInventory API is not considering the locale of the ShipNode

Question & Answer


Question

Why does findInventory API not consider the locale of the ShipNode passed in the input in IBM Sterling Order Management?

Cause

You are unable to calculate node capacity.

Answer

FindInventory API is not called for a store; it is called for inventory organization. Hence it will not honor the timezone of the ShipNode being passed in API input. Additionally, Current product design does not support the consideration of "Time" component for Inventory and capacity consumption. Solution is to check the inventory from Store with Store user. In this case the timezone of the store user is honored.

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Document Information

Modified date:
10 May 2022

UID

swg21984255