IBM Support

Planning Analytics Workspace is not accessible after some time

Troubleshooting


Problem

After some time Planning Analytics Workspace isn't accessible anymore. The mongo and neo-provision container are stopped, which results into the problem in not able to access Planning Analytics Workspace anymore.

Symptom

Planning Analytics Workspace isn't accessible anymore, some of the container (mongo and neo-provision) get stopped without any request from an admin user or in use the paw script to stop and start or the Planning Analytics Workspace Admin Tool.
 
The following last messages could be found in the log files:
mongo -> mongo.log:
...
2020-01-23T14:39:20.221+0100 I NETWORK  [initandlisten] connection accepted from 127.0.0.1:49165 #9 (5 connections now open)
2020-01-23T14:39:20.230+0100 I COMMAND  [conn9] terminating, shutdown command received
2020-01-23T14:39:20.230+0100 I FTDC     [conn9] Shutting down full-time diagnostic data capture
2020-01-23T14:39:20.235+0100 I CONTROL  [conn9] now exiting
2020-01-23T14:39:20.235+0100 I NETWORK  [conn9] shutdown: going to close listening sockets...
2020-01-23T14:39:20.235+0100 I NETWORK  [conn9] closing listening socket: 536
2020-01-23T14:39:20.235+0100 I NETWORK  [conn9] shutdown: going to flush diaglog...
2020-01-23T14:39:20.235+0100 I NETWORK  [conn9] shutdown: going to close sockets...
2020-01-23T14:39:20.235+0100 I STORAGE  [conn9] WiredTigerKVEngine shutting down
2020-01-23T14:39:20.235+0100 I NETWORK  [conn8] end connection 172.25.23.170:49233 (4 connections now open)
2020-01-23T14:39:20.235+0100 I NETWORK  [conn6] end connection 172.25.29.212:49169 (4 connections now open)
2020-01-23T14:39:20.236+0100 I NETWORK  [conn7] end connection 172.25.23.170:49232 (4 connections now open)
2020-01-23T14:39:20.236+0100 I NETWORK  [conn5] end connection 172.25.29.212:49168 (4 connections now open)
2020-01-23T14:39:20.250+0100 I STORAGE  [conn9] shutdown: removing fs lock...
2020-01-23T14:39:20.250+0100 I CONTROL  [conn9] dbexit:  rc: 0

neo-provision -> messages.log:
...
[1/23/20 14:39:38:752 CET] 00000045 com.mongodb.driver.cluster                                   I Exception in monitor thread while connecting to server mongo:27017
com.mongodb.MongoException$Network: Exception opening the socket
    at com.mongodb.DBPort.<init>(DBPort.java:117)
    at com.mongodb.DBPort.<init>(DBPort.java:100)
    at com.mongodb.ServerMonitor$ServerMonitorRunnable.run(ServerMonitor.java:103)
    at java.lang.Thread.run(Thread.java:812)
Caused by: java.net.ConnectException: Connection timed out: connect
    at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:96)
    at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:380)
    at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:236)
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:218)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:183)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:403)
    at java.net.Socket.connect(Socket.java:666)
    at com.mongodb.DBPort.ensureOpen(DBPort.java:286)
    at com.mongodb.DBPort.<init>(DBPort.java:113)

Cause

Planning Analytics Workspace is installed in a Windows 2016 VMWare installation. With this the VMWare Tools 11.0.1 were installed on this Windows 2016 system. This VMWare Tools interfere with Docker and Planning Analytics Workspace.

Environment

Windows 2016
VMWare Environment with VMWare Tools 11.0.1 installed on Windows 2016 system

Resolving The Problem

To solve the issue, try one of the following options:
-Upgrade VMWare Tools to version 11.0.6 or higher
-Uninstall VMWare Tools 11.0.1 on the Windows 2016 system, if it is not required

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"Planning Analytics Workspace","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.0.36, 2.0.46, 2.0.48","Edition":"Planning Analytics Workspace","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Product Synonym

PAW

Document Information

Modified date:
03 February 2023

UID

ibm12801175