IBM Support

Return order payment status is changing to PAID before invoicing the return order.

Troubleshooting


Problem

Running ProcessOrderPayment API changes the order payment status to PAID in IBM Sterling Order Management.

Symptom

Steps to reproduce:

  1. Create a return order by passing attribute ProcessPaymentOnReturnOrder="Y".
    Payment status is AUTHORIZED.


  2. Run ProcessOrderPayment API.
    Settlement takes place before invoicing and order payment status moves to PAID.

Cause

This is working as designed.

Diagnosing The Problem

The created return order if has book amount as 0 and no invoice in the system with no amount to refund then order status will be set to PAID. Record in YFS_CHARGE_TRANSACTION table will be populated only when the return order is invoiced. Only then the payment system could set the payment status on the return order.

Resolving The Problem

As per design for an return order, payment status will be set to PAID if you run requestCollection API without having an invoice for return order. Return order payment status should not stop user from further processing the return order. If you create an invoice for the return order, payment agents will pick this return order and process it for refunds even if the return order is in PAID status.

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Document Information

Modified date:
10 May 2022

UID

swg21983475