IBM Support

The ad-hoc process box covers my reports in the IBM Security Guardium GUI

Troubleshooting


Problem

In the Guardium GUI, the ad-hoc process box prevents me from viewing my reports in some cases.

Symptom

Example of what the problem looks like on the GUI:

Cause

There are crashed tables in the internal TURBINE database. There can be many reasons why these tables crashed, one of which being:

Restart of database - If the database restarts during any major process (Guardium related or not), this can leave tables "open" or corrupt on database startup.
Due to this, the process that manages the GUI will not be able to read the necessary information from said tables, causing this issue and possibly others.

Diagnosing The Problem

Finding where the issue lies may vary depending on the environment.

Standalone unit - Collect a system_db_info must_gather from this appliance.

Managed unit - The issue may not be on the current appliance. It is possible that the Central Manager has the crashed tables. When the managed unit attempts to gather information necessary for displaying the page in the GUI, this issue may occur. In this case, it is important to get a system_db_info must_gather from both the managed unit and the Central Manager

Once the must_gather has been collected


You can check on the status of the database in the mysql error log within it. This log is named differently depending on whether the system is 32 bit or 64 bit.
- 32 bit error log is named [hostname].err 
- 64 bit error log is named mysql-error.log

The messages that could indicate a problem are as follows:
[ERROR] 
[Warning]
 
InnoDB: Rolling back trx with id
 

Here is an example of a crashed table that you could see in this log:
2016-01-13 08:01:01 4593 [ERROR] /usr/sbin/mysqld: Table './TURBINE/TURBINE_USER_GROUP_ROLE' is marked as crashed and should be repaired

Resolving The Problem

Once identifying a potential issue by following the diagnostic steps above, you should provide your findings, along with the system_db_info must_gather to Guardium Support, explaining the issue.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
12 December 2019

UID

swg21982064