IBM Support

Install of WAS 8.5.5 fails on Windows 2012 R2

Troubleshooting


Problem

Operating System was not detected error when installing WebSphere Application Server 8.5.5 on Windows 2012 R2

Symptom

When trying to install WebSphere Application Server 8.5.5 on Windows 2012 R2 the error received is


A supported operating system was not detected. Support for your operating system might have been added after the release of the product. See the WebSphere Application Server detailed system requirements Web pages -
http://www.ibm.com/support/docview.wss?rs=180&uid=swg27006921 for more information about supported operating systems. You can continue with the installation, but the installation or product operation might not succeed without applying maintenance. Go to the product support Web pages -
http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980 to obtain the latest maintenance packages to apply after installation.

Cause

Support for Pre-req for Windows 2012 R2 starting 8.5.5.8.

Resolving The Problem

If you install WAS 8.5.5.8 and higher the error will not be seen.

For installing on the versions between 8.5.5 and 8.5.5.7 To bypass operating system prerequisite checking, add disableOSPrereqChecking=true to the config.ini file in IM_install_root/eclipse/configuration and restart Installation Manager



IM_install_root is directory where Installation Manager is installed.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Install","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.5.7;8.5.5.6;8.5.5.5;8.5.5.4;8.5.5.3;8.5.5.2;8.5.5.1;8.5.5","Edition":"Base;Express;Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21981243