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Installing Rational Rhapsody Application Help Server from Release 8.1.4

Question & Answer


Question

How do you install the IBM Rational Rhapsody Knowledge Center Application to work without an External Browser, from release 8.1.4 onwards?

Cause

In previous releases of Rational Rhapsody, a compressed help-content file was used to provide the user with the online help. However, in release 8.1.4 onwards, a local web server is used to provide help.

Between releases 813 and 814 of Rhapsody, the IBM help infrastructure team made significant changes to the help system. As a result, you can not just follow the process that you may have used to install a local copy of the help in Rhapsody 813 or earlier.

Answer

To install and use a local copy of the Rhapsody 8.1.4 help, follow these steps:

1) Go to the help download page: http://download.boulder.ibm.com/ibmdl/pub/software/rationalsdp/documentation/

2) Click the kcci_product_help link.

3) When the list of products is displayed, click rhapsody814.

4) Select the .zip file that corresponds to your operating system (and whether it is 32-bit or 64-bit).

5) When the file has finished downloading, extract it to a directory on your computer.
Note that the file you downloaded contains both the help content and a help server (as opposed to just the help content, as was the case in previous releases).

6) Once you have extracted the files, go to the directory KnowledgeCenter\bin, and start the help server by running the file startKC.bat (or the corresponding script for Linux).

7) Once the help server is running, you can access the help directly in a browser at this url: http://localhost:9090/kc

Note that if port 9090 is in use, the help server will use a different port. The port number is briefly displayed in the startup window. After the window closes, you can find the port number in the file ../KnowledgeCenter/logs/port.properties


Now carry out the following steps to instruct the help application that is included with Rhapsody to point to the content that you downloaded (so that you can access the help from within Rhapsody):

1) Select Help > Help Contents from the main Rhapsody menu.

2) Once the help application opens, go to the help preferences window: Help > Preferences.

3) On the left side of the Preferences window, select Help > Content. The table lists any help URLs that have already been defined.

4) Use the buttons to disable any URLs for external sites.

5) Select New to add a new URL.

6) When the "Add new information center" window is displayed, provide a name for the entry and paste in the following for the URL: http://localhost:9090/kc/SSB2MU_8.1.4
(Note that this URL differs slightly from the URL you would use in an ordinary browser.)

7) Click OK.

8) Verify that the new entry is marked Enabled.

9) In the Preferences window, click OK.

10) To refresh the help, select Help > Help Contents.

Note that in order to use the local help, you must run the help server each time that you run Rhapsody. You may want to set up a batch file that runs the help server each time that you start Rhapsody.
Silently Installing this feature does not exist. This has been identified as a product defect under APAR PI58716 as a regression.

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Product Synonym

Rational Rhapsody

Document Information

Modified date:
27 May 2022

UID

swg21980999