IBM Support

Can not install Guardium installation manager (GIM) due to tar error

Troubleshooting


Problem

Installing UNIX GIM from the command line fails even though there is a message at the end saying "Installation completed successfully". On the command line there are errors like: mv: config.all.11203: cannot access: No such file or directory cp: cannot access *.tar.gz*: No such file or directory

Symptom

Example output from the installer with the error:


    [root@dbserver] ./guard-bundle-GIM-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim.sh -- --dir
    /opt/guardium --sqlguardip 10.1.1.1 --tapip 10.2.2.2 --perl /usr/bin/
    Verifying archive integrity... All good.
    Uncompressing Guard BUNDLE-GIM Installer....
    guard-BUNDLE-GIM-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim
    guard-GIM-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim
    guard-INIT-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim
    guard-SUPERVISOR-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim
    guard-UTILS-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim
    mv: config.all.11203: cannot access: No such file or directory
    cp: cannot access *.tar.gz*: No such file or directory
    cat: Cannot open config.all: No such file or directory
    cat: Cannot open config.all: No such file or directory
    Installing modules ....
    Installation completed successfully


The example is for GIM-9.0.0_r48064 on HPUX but the same issue can happen with any GIM version or OS. The number in:

    config.all.11203

may also be different in different cases.

Cause

The "tar" command on the server is not working correctly. Working tar is a requirement to install GIM.

Diagnosing The Problem


In previous cases of this problem the tar binary has been found in an unusual location:

    [root@dbserver] which tar
    /usr/openv/netbackup/bin/tar

Compared to servers where GIM can be installed with no error:

    [root@dbserver2]# which tar
    /usr/bin/tar

Check the location of the tar binary on the system with the above command. If it is not in /usr/bin/tar the below solution applies.

Resolving The Problem

1. Try to reinstall the tar binary on the server in case it has been corrupted. If the GIM install fails with the same error use the workaround in 2.

2. Edit the .gim.sh installer file so that the tar function uses the path to tar specific on the server. e.g.


    [root@dbserver] vi guard-bundle-GIM-9.0.0_r48064_v90_1-hpux-B.11.31-hpux-ia64.gim.sh

Change the UnTAR function:

    UnTAR()                                                                
    {                                                                      
       
    tar $1vf - 2>&1 || { echo Extraction failed. > /dev/tty; kill -15  
       $$; }                                                              
    }

To use the full path from "which tar":

    UnTAR()                                                                
    {                                                                      
       
    /usr/openv/netbackup/bin/tar $1vf - 2>&1 || { echo Extraction failed. >
    /dev/tty; kill -15  
       $$; }                                                              
    }

Save the file and retry the GIM install with the same command as previously.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"10.0;8.2;9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21972824