Troubleshooting
Problem
Attempts to schedule order with DeliveryMethod=PICK is leading to cancellation of the order in IBM Sterling Order Management.
Symptom
Steps to reproduce:
- Setup Node capacity for a Node (NodeType-Store) with DeliveryMethod=Ship.
- In the scheduling rule, enable Cancel Order For Inventory Shortage.
- In Sterling Business Center (SBC), check the node capacity for Delivery Method - Ship. and Keep the Delivery Method - Pickup as unchecked.
- Create an Order with DeliveryMethod="PICK".
- Schedule the Order
NOTE::
PICKUP is purposely unchecked in SBC configuration. But having PICKUP unchecked is forcing cancellation of PICKUP order during scheduling.
Cause
This is working as designed.
Diagnosing The Problem
Once the Node Capacity is removed for the Node then the order with DeliveryMethod=PICK is scheduled.
Resolving The Problem
Node capacity is capacity of a node to fulfill irrespective of delivery method. When node capacity for Delivery Method - Pickup is unchecked, it will not create a capacity resource pool for Pickup & hence can't be used by the orders.
- If you do not select Delivery Method on Capacity resource pool:
Resource pool will be used for All delivery Methods.
- If Resource pool to be used for PICK and SHIP separately:
Define Resource pool with selecting delivery method PICK for Pick Up
Define Resource pool with selecting delivery method SHIP for Ship and Delivery
[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.4;9.3;9.2.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Was this topic helpful?
Document Information
Modified date:
10 May 2022
UID
swg21972128