Troubleshooting
Problem
Attempts to create Search Index fails with the error YCP85_0011 - Failed merging Index sets in IBM Sterling Order Management.
Symptom
The complete error is as follows:
ERRORDTL:Thread-28_INDEX_BUILD: [1443236128140]<?xml version="1.0" encoding="UTF-8"?>
<Errors>
<Error ErrorCode="YCP85_0011"
ErrorDescription="Failed merging Index sets."
ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="161.228.111.5414432361277970000000000002">
<Attribute Name="ErrorCode" Value="YCP85_0011"/>
<Attribute Name="ErrorDescription" Value="Failed merging Index sets."/>
<Error
ErrorCode="org.apache.lucene.store.NoSuchDirectoryException"
ErrorDescription="" ErrorRelatedMoreInfo="directory '/ibmcpq/IBM/Shares/prod/SearchIndex/SearchIndex/MasterCatalog/CatalogIndex_2015092522092011/1' does not exist"> <Stack>org.apache.lucene.store.NoSuchDirectoryException:
directory '/ibmcpq/IBM/Shares/prod/SearchIndex/SearchIndex/MasterCatalog/CatalogIndex_2015092522092011/1' does not exist
at org.apache.lucene.store.FSDirectory.listAll(FSDirectory.java:218) at org.apache.lucene.store.FSDirectory.listAll(FSDirectory.java:241) at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run (SegmentInfos.java:602)
at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run SegmentInfos.java:554)
at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java: 359)
at org.apache.lucene.index.IndexWriter.addIndexes(IndexWriter. java:3129)
at com.yantra.ycp.business.search.YCPIndexBuildUtility.mergeIndexSets(YCPIndexBuildUtility.java:51) at com.yantra.ycm.agent.YCMCatalogIndexBuildAgent.mergeIndexSets(YCMCatalogIndexBuildAgent.java:925)
.
.
.
</Stack>
</Error>
</Errors>
Cause
Incorrect data was loaded in YFS_ITEM_LOCALE table.
Diagnosing The Problem
The index files are getting created but were deleted since the agent was unable to merge the files.
The YFS_INSTALL_DEFAULTS table contains the record for en_US locale.
Run the below SQL:
Select * from yfs_item where item_key in <select item_key from yfs_item_locale where country is null>;
There were many items in YFS_ITEM_LOCALE table for which country column had null value. Also the columns language and Short_Description contained null values for such items.
Resolving The Problem
Steps to resolve:
- Reload the YFS_ITEM_LOCALE table with the correct data containing appropriate values in country and language columns.
- Rerun the Search Index.
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Document Information
Modified date:
10 May 2022
UID
swg21972123