IBM Support

How can I disable ACTIVATE_PCA_CALLBACK rule

Question & Answer


Question

Even though none of the PCAs are installed, ACTIVATE_PCA_CALLBACK rule is set to Y as part of Foundation installation. How can I disable this rule?

Cause

This rule is checked by transactions like scheduleOrder, changeOrder etc in particular scenarios. If this is set to Y, product performs some internal checks, logs notes and invokes the services configured at 'Define Order Node Types and Configure Automatic Note Logging' in Channel Applications Manager.

In case none of the PCAs are installed, it might not be desired to perform any of these actions.

Answer

This rule is part of the Foundation Application Add in installer. If you are not using any of the PCAs like Call Center Order Management(COM) or Store Order Management(SOM), you can disable the rule by calling manageRule API. Sample input -

<Rules Action="" DocumentType="" OrganizationCode="DEFAULT"
QualifiedTagId="" RuleSetFieldDescription=""
RuleSetFieldName="ACTIVATE_PCA_CALLBACK" RuleSetValue="N" RuleType=""
RulesKey="ACTIVATE_PCA_CALLBACK"/>

In case you choose to use the PCAs at some point in the future, it is recommended to enable this back.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 May 2022

UID

swg21969761