Troubleshooting
Problem
Attempts to finalize the Configuration and Change Management (CCM) application when re-running setup for IBM Rational Team Concert (RTC) results in the error "The "com.ibm.team.repository.service.internal.setup.SetupCompletionService" service failed to activate because a service that it depends on, "com.ibm.team.repository.common.service.IContributorService", failed to be activated.ID CRJAZ1972E com.ibm.team.repository.common.transport.TeamServiceRegistryException com.ibm.team.repository.common.transport.internal.registry.AbstractActivationManagerOwner.buildServicesMap(AbstractActivationManagerOwner.java:384) com.ibm.team.repository.common.transport.internal.registry.AbstractActivationManagerOwner.doActivate(AbstractActivationManagerOwner.java:753) com.ibm.team.repository.common.transport.internal.registry.ServiceProviderActivationManagerOwner.getService(ServiceProviderActivationManagerOwner.java:132) com.ibm.team.repository.common.transport.internal.registry.OsgiServicesManager.getService(OsgiServicesManager.java:291) com.ibm.team.repository.common.transport.internal.registry.OsgiServicesManager.getService(OsgiServicesManager.java:300) com.ibm.team.repository.common.transport.internal.registry.OsgiServicesManager.getServiceForRemoteAccess(OsgiServicesManager.java:695) com.ibm.team.repository.servlet.AbstractTeamServerServlet.handleRequest2(AbstractTeamServerServlet.java:2434) ... Caused by: Failed to find the service "com.ibm.team.repository.service.compatibility.internal.IJtsConfigurationStateService" with a matching filter "(validJtsConfig=true)". Use the administrative UI to verify that the server and applications are configured correctly. (com.ibm.team.repository.common.transport.internal.registry.ServiceNotFoundCheckedException)ID CRJAZ1135I com.ibm.team.repository.common.transport.internal.registry.ServiceProviderActivationManagerOwner.getService(ServiceProviderActivationManagerOwner.java:141) com.ibm.team.repository.common.transport.internal.registry.OsgiServicesManager.getService(OsgiServicesManager.java:291) com.ibm.team.repository.common.transport.internal.registry.OsgiServicesManager.getService(OsgiServicesManager.java:300) com.ibm.team.repository.common.transport.internal.registry.AbstractActivationManagerOwner.buildServicesMap(AbstractActivationManagerOwner.java:373) ... 74 more."
Cause
The CCM application is not registered correctly in the Jazz Team Server (JTS).
Resolving The Problem
Re-register the CCM application in the Jazz Team Server. Use the steps described in
Registering applications with the Jazz Team Server
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Document Information
Modified date:
17 June 2018
UID
swg21968136