IBM Support

Pre-allocate the dsmerror.log file (for TSM error logging) on Security Guardium appliance

Troubleshooting


Problem

To avoid permission issues on the dsmerror.log file, and to ensure it is available to view under fileserver, install patch v9p1215

Symptom

The 'test file' send fails when configuring the TSM server on an appliance and you can not view the TSM error in dsmerror.log.

Cause

By default the dsmerror.log file is allocated in the directory where the dsmc command is issued. This results in the dsmerror.log file being allocated in a directory not accessible to the Guardium users.

Resolving The Problem

A new support patch, SqlGuard-9.0p1215.tgz.enc, pre-allocates the dsmerror.log file under /var/log/guard with global read and write access. Thereby enabling Guardium users to view any TSM errors and removing any permission issues on that file. To fully implement this dsmerror.log file, follow these steps:

  1. For v9 environments at v9p500 or earlier, request the SqlGuard-9.0p1215.tgz.enc patch from Guardium support - via a PMR. This patch will be implemented in the next GPU for v9 in which case, please skip ahead to step 4 - "Modify your dsm.sys ....." below.
  2. Using the normal Guardium patch process, upload and install SqlGuard-9.0p1215.tgz.enc on the Guardium appliance.
  3. Once SqlGuard-9.0p1215.tgz.enc is installed, using the cli fileserver, verify the dsmerror.log file is allocated in /var/log/guard.
  4. Modify your dsm.sys file, adding the following line (or modifying an existing 'errorlogname' entry):
    • errorlogname /var/log/guard/dsmerror.log
    In additional to that, remove all other local directory or file references from the dsm.sys. This is a precautionary measure as any such definitions would almost certainly conflict with the directory structure on the appliance.

After all customization is complete, upload the modified dsm.sys file to the appliance using the normal cli interface.

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Document Information

Modified date:
16 June 2018

UID

swg21903002