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OS User is blank in Guardium report for Netezza databases

Troubleshooting


Problem

You are monitoring Netezza database with IBM InfoSphere Guardium. Your report shows blank for field OS USER.

Symptom

OS USER is blank (missing value) in the report for Netezza connections.

Cause

As of the last revision of this Technote, the Netezza client is not sending the OS USER (nor Source Program) at the Netezza protocol level (TCP layer) thus the sniffer on Guardium collector can not extract it.

Environment

IBM Infosphere Guardium monitoring Netezza database.

Diagnosing The Problem

OS USER is blank/missing for Netezza databases in the Guardium reports.

Resolving The Problem

Solution: Ask Netezza Support to implement sending the OS USER at the protocol level so Guardium can read it.

You can use one or a combination of these workarounds in the mean time:

a) Use "Application Events API" to identify the OS USER. These are dummy SQLs you can program at the beginning of your application logins to identify the user (this requires you to modify your application source code to include these calls). Refer to "Identify Users via API" in the Related URL section in this Technote for details.

b) Use Custom Identification Procedures to identify the OS USER. This is alternative to the API also to aid in identifying users, but via stored procedures instead. Refer to "Identify Users via Stored Procedures" in the Related URL section in this Technote for details.

c) For Unix based local connections, enable UID Chain and add UID CHAIN field to your reports to see OS User this way. Refer to "K-TAP and UIDChains" in the Related URL section in this Technote for details.



Note: For Windows based servers, STAP normally captures the OS User for local connections (because it can extract the process owner).

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Document Information

Modified date:
16 June 2018

UID

swg21883445