IBM Support

/var/spool/clientmqueue keeps filling and causes /var filesystem usage exceeded threshold

Troubleshooting


Problem

/var/spool/clientmqueue keeps filling and causes /var filesystem usage exceeded threshold

Symptom

/var file system space are filling up fast for unknown reason.

Cause

If sendmail service is disabled, the unsent messages sent to the /var/spool/clientmqueue, the later will then create files under /var for the unsent messages. This will eventually filled up the file-system space.

Diagnosing The Problem

There files under /var are filling it up the /var filesystem space.
-rw-r----- 1 root root  66601150 Jul 26 11:48 acpid
-rw-r----- 1 root root 205306753 Jul 26 04:02 acpid.1
-rw-r----- 1 root root 205388673 Jul 25 04:02 acpid.2
-rw-r----- 1 root root 206023553 Jul 24 04:02 acpid.3
-rw-r----- 1 root root 206412673 Jul 23 04:02 acpid.4


Check if the sendmail service are started : "service sendmail status", this problem occurred when the service is stopped.

Resolving The Problem

If the sendmail service are not started, run "service sendmail start" ; the sendmail service will then start processing the mail queue and reduce the file-system space usage.

Having the service started can also prevent the issues from re-occurring , because the unsent message will no longer going into the spool files.

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Host","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21882660