IBM Support

Guardium Aggregation/Archive Log returning 'No Data Found'

Troubleshooting


Problem

In the Guardium appliance GUI->Guardium Monitor->Aggregation/Archive Log is returning 'No Data Found' despite the archive/export/purge/aggregation processes running correctly.

Cause

One cause of this problem is that the appliance hostname has not yet been set.
This is assuming the aggregation processes are actually running, which you can confirm with the steps in Diagnosing the problem.

Diagnosing The Problem

To first check if the aggregation processes are actually running:


    1. In the CLI run the command fileserver
    2. Enter the address it gives you in the browser and select Sqlguard logs
    3. Find and then open launch_agg.log and agg_progress.log
    4. In these files check the date of the latest entry.

If that date is newer than 7 days then the aggregation processes are running and not the problem.
If the date is older than 7 days this indicates a problem with the aggregation processes outside the scope of this technote. If you do not expect this, you should raise a PMR with Guardium Support.

You can check if the hostname has been changed by running the following in the CLI
guard.ibm.com> show system hostname
guard
If this returns guard then it is very probable the hostname has not been set, as this is the default hostname.

Resolving The Problem

To resolve this issue you must set the hostname of the machine.
You can choose any hostname, however it is good practice to follow a set naming practise for the hostnames.
guard.ibm.com> store system hostname col22
ok

If the above command does not complete, or times out, please contact Guardium support and reference this technote.

When the next archive, export or purge runs the Aggregation/Archive Log will update normally.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"9.1;9.0;8.2;8.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
12 December 2019

UID

swg21688437