Troubleshooting
Problem
Attempts to start an IBM Rational Synergy client fails with "CRCCK2028E Incompatible database version. The server installation release is incompatible with the database
Symptom
After successfully applying Rational Synergy Fix Pack 3 (7.2.1.3) for 7.2.1 to a database that had no other 7.2.1 Fix Packs applied to it, the following message is displayed when a client is started:
CRCCK2028E Incompatible database version.
The server installation release is incompatible with the database <DATABASE_PATH>
Cause
This is due to a mismatch between patches.dat
in the Rational Synergy Server and the database. This mismatch should not matter in the circumstances described above.
This issue has been identified as a product defect and has been logged under APAR PI26904
Environment
When a Rational Synergy server was updated as follows:
- Synergy 7.2.1 Installed.
- Synergy 7.2.1.1 (Fix Pack) was then applied.
- Synergy 7.2.1.2 (Fix Pack) was then applied.
- A database is newly created in 7.2.1 or upgraded to this version and where the above two fix packs have not been applied to the database.
- 7.2.1.3 is then applied to the Rational Synergy server and the database successfully.
Resolving The Problem
To resolve the problem:
- Apply the 7.2.1.3 fix pack to the database again and make sure it completes successfully.
- Update the database with the correct
patches.dat
file
- Login as user
ccm_root
, - Copy the
patches.dat
file:
cp -p $CCM_HOME/etc/patches.dat <DATABASE_PATH>/etc/patches.dat
Was this topic helpful?
Document Information
Modified date:
22 December 2020
UID
swg21686105