IBM Support

How to debug Agent Connectivity issues (with WebSphere Application Server)

Troubleshooting


Problem

Problems when starting an Agent that integrated with WebSphere Application Server (WAS) embedded messaging. The error message 'connection refused' was thrown.

Symptom

When trying to start an Agent, the following error message was logged:

<Stack>javax.naming.NamingException: Error getting WsnNameService properties [Root exception is org.omg.CORBA.TRANSIENT: initial and forwarded IOR inaccessible  vmcid: IBM  minor code: E07  completed: No]
    at com.ibm.ws.naming.util.WsnInitCtxFactory.mergeWsnNSProperties(WsnInitCtxFactory.java:1552)
    at com.ibm.ws.naming.util.WsnInitCtxFactory.getRootContextFromServer(WsnInitCtxFactory.java:1042)
    at com.ibm.ws.naming.util.WsnInitCtxFactory.getRootJndiContext(WsnInitCtxFactory.java:962)
    at com.ibm.ws.naming.util.WsnInitCtxFactory.getInitialContextInternal(WsnInitCtxFactory.java:614)
    at com.ibm.ws.naming.util.WsnInitCtx.getContext(WsnInitCtx.java:128)
    at com.ibm.ws.naming.util.WsnInitCtx.getContextIfNull(WsnInitCtx.java:765)
    at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:164)
    at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:179)
    at javax.naming.InitialContext.lookup(InitialContext.java:436)
    at com.yantra.interop.services.jms.JMSContext.getConnectionFactoryFromJNDI(JMSContext.java:301)
    at com.yantra.interop.services.jms.JMSContext.configure(JMSContext.java:120)
    at com.yantra.integration.adapter.IntegrationAdapter.initConfig(IntegrationAdapter.java:165)
    at com.yantra.integration.adapter.IntegrationAdapter.start(IntegrationAdapter.java:381)
    at com.yantra.integration.adapter.IntegrationAdapter.main(IntegrationAdapter.java:515)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
    at java.lang.reflect.Method.invoke(Method.java:611)
    at com.sterlingcommerce.woodstock.noapp.NoAppLoader.main(NoAppLoader.java:90)
Caused by: org.omg.CORBA.TRANSIENT: initial and forwarded IOR inaccessible  vmcid: IBM  minor code: E07  completed: No
    at com.ibm.rmi.corba.ClientDelegate.createRequest(ClientDelegate.java:1276)
    at com.ibm.CORBA.iiop.ClientDelegate.createRequest(ClientDelegate.java:1457)
    at com.ibm.rmi.corba.ClientDelegate.createRequest(ClientDelegate.java:1164)
    at com.ibm.CORBA.iiop.ClientDelegate.createRequest(ClientDelegate.java:1423)
    at com.ibm.rmi.corba.ClientDelegate.request(ClientDelegate.java:1886)
    at com.ibm.CORBA.iiop.ClientDelegate.request(ClientDelegate.java:1379)
    at org.omg.CORBA.portable.ObjectImpl._request(ObjectImpl.java:458)
    at com.ibm.WsnBootstrap._WsnNameServiceStub.getProperties(_WsnNameServiceStub.java:38)
    at com.ibm.ws.naming.util.WsnInitCtxFactory.mergeWsnNSProperties(WsnInitCtxFactory.java:1549)
    ... 18 more
Caused by: java.net.ConnectException: Connection refused: connect
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:381)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:243)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:230)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:377)
    at java.net.Socket.connect(Socket.java:539)
    at com.ibm.ws.orbimpl.transport.WSTCPTransportConnection.createSocket(WSTCPTransportConnection.java:313)
    at com.ibm.CORBA.transport.TransportConnectionBase.connect(TransportConnectionBase.java:357)
    at com.ibm.ws.orbimpl.transport.WSTransport.getConnection(WSTransport.java:437)
    at com.ibm.CORBA.transport.TransportBase.getConnection(TransportBase.java:187)
    at com.ibm.rmi.iiop.TransportManager.get(TransportManager.java:97)
    at com.ibm.rmi.iiop.GIOPImpl.getConnection(GIOPImpl.java:130)
    at com.ibm.rmi.iiop.GIOPImpl.locate(GIOPImpl.java:219)
    at com.ibm.rmi.corba.ClientDelegate.locate(ClientDelegate.java:1983)
    at com.ibm.rmi.corba.ClientDelegate._createRequest(ClientDelegate.java:2008)
    at com.ibm.rmi.corba.ClientDelegate.createRequest(ClientDelegate.java:1186)
    at com.ibm.rmi.corba.ClientDelegate.createRequest(ClientDelegate.java:1272)
    ... 26 more
</Stack>

Cause

The cause can vary on several connection settings in WebSphere Application Server. Mainly this error is Security related.

Diagnosing The Problem

To debug such problems you need to enable ORB Comm Traces on WAS as well as on Agent side :

Configure a WAS ORB Comm Trace

1. From the WAS Administrative Console, select Servers > Application Servers > server_name > Change Log Details Levels.
2. Remove any previous entries in the text field type the following:
*=info:ORBRas=all
3. Apply and save changes.
4. Select Servers > Application Servers > server_name > Diagnostic Trace Service.
5. Change the Maximum Number of Historical Files to 10 and maximum file size to 50mb
6. Apply and save changes.
7. Enabling Comm Trace: From the Administrative Console, Select Servers > Application Servers > server_name > Container Services > ORB Service. Select the Orb Tracing check box to enable Comm Tracing.
8. Apply and save changes.
9. Stop the server, recycle the logs in <WAS_PROFILE_HOME>/logs/ffdc/* and <WAS_PROFILE_HOME>/logs/<SERVER>/*
10. Recreate the problem
11. Zip all contents in <WAS_PROFILE_HOME>/logs

Configure a Agent ORB Comm Trace :

1. Edit your <FOUNDATION_HOME>/bin/agentserver.cmd/.sh and add the following JVM param into the AGENT_JAVA_OPTS:
-Dcom.ibm.CORBA.Debug=true -Dcom.ibm.CORBA.CommTrace=true
2. Start the agent by adding the following cmdline parameters :

    -CCtrace=ORBRas=all -CCtracefile=orbtrace.txt -CCtraceMode=basic
Example:
    agentserver.cmd/.sh TestAgent -CCtrace=ORBRas=all -CCtracefile=orbtrace.txt -CCtraceMode=basic
3. Agent logs are located at <FOUNDATION_HOME>/logs, the ORB Comm trace is located at <FOUNDATION_HOME>/bin/orbtrace*

Zip the WAS and FOUNDATION logs and upload them to your Service Request via https://www.ecurep.ibm.com/app/upload

Resolving The Problem

Based on the ORB Comm trace, IBM Support will be able to provide problem determination. Please contact IBM Support.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Maintenance","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.3;9.2.1;9.2;9.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 May 2022

UID

swg21685945