Question & Answer
Question
Event assignment : Why can users not take ownership of events already owned?
Cause
The Netcool/OMNIbus Event Security Model prevents assigned events from being reassigned by normal users
Answer
Normal users are not allowed to take ownership of events that have already been assigned to a user.
Only administrators are allowed to reassign events, by default.
This behaviour also prevents normal users from acknowledging alarms that are assigned to a user.
Some customers have requested that normal users should be allowed to reassign alarms, and development have asked that customers who require this behaviour raise an request for enhancement.
It is possible to circumnavigate the alerts.status security model, using custom tables and triggers, as normal users can be allowed access to customer tables, and triggers are actioned by the Netcool/OMNIbus administrator.
With this in mind a Support's Guide to Event Ownership Tools has been written and an example ownership.sql file provide here.
Installation overview:
- Apply the event ownership tables and triggers to the object server using:
cat ownership.sql | nco_sql -server NCOMS -user root -password ''
- Add the event list tools given in the guide
- Add custom Web GUI tools as required
It is possible to audit users who use these tools, and to have events reassigned to the user nobody and group Public to allow normal auditing, if required.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21683582