Troubleshooting
Problem
User configured to use TSM for Guardium system backup. In Guardium GUI, it always failed to save the TSM configuration.
Symptom
In Guardium GUI -> Administration Console -> Data Management -> System Backup, after inputting all required fields and clicking "Apply" button to save the TSM configuration, got following error:
Please correct the following errors and try again:
Failed to send a test file to the tsm destination. There might be some misconfiguration.
However, user can confirm all fields have been inputted correctly. It's unclear what is the misconfiguration.
Cause
It could be related to the dsmerror.log file permission.
Diagnosing The Problem
To confirm it's related to dsmerror.log file permission, you can enable Guardium Application Debug log by using following cli command:
support must_gather app_issues
After issuing the command, try to reproduce the above error. Once the must gather file is generated, check the Application Debug log(named as yyyy-mm-dd-debug.log). You can confirm you are hitting this issue if you see similar error as below:
==============Thu Sep 04 15:10:15 KST 2014===================
Thread: Thread-108920 - ProcessStreamReaderThread reads:ANS1398E Initialization functions cannot open one of the Tivoli Storage Manager logs or a related file: /opt/tivoli/tsm/client/ba/dsmerror.log. errno = 13, Permission denied
=============================================================
Resolving The Problem
Please contact IBM Guardium Support who will consult the Internal notes for this TechNote and correct the file permissions accordingly.
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Document Information
Modified date:
16 June 2018
UID
swg21683468