Troubleshooting
Problem
When the User clicks View Status History from the Select Action menu in the Job Plans application, nothing happens.
Symptom
Steps to Reproduce:
- Go To Planning | Job Plans
- Press Enter in the Job Plan field
- Click on any record
- Select Action | View Status History
Cause
There a value in the maxmenu object that is different than the value which is referenced in the jobplan.xml file for this dialog box presentation. A likely cause for this condition is that the same database has been upgraded and migrated from several previous versions of Maximo.
Environment
Maximo 7.1.1.x and 7.5.0.x
Diagnosing The Problem
When the User performs the steps above, nothing happens but there will be messaging similar to this in the bottom-left corner of the browser:
javascript:topLevelMenus['shared'].menuClick({"id":0_VIEWHISTOR_OPTION","text";"View Status
History","value":0_VIEWHISTOR_OPTION","target":"jobplan_mainrec_menus","event":"click"});
Resolving The Problem
Update the database with the following sql statement, and then restart the application (maximo) server.
update maxmenu
set keyvalue = 'VIEWHIST'
where moduleapp = 'JOBPLAN'
and keyvalue = 'VIEWHISTOR'
commit;
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21668888