IBM Support

WebSphere Application Server fails to start due to error at VM initialization

Troubleshooting


Problem

WebSphere Application Servers fail to start with an apparent out of memory condition that is not reflected as heap space problem.

Symptom

New WebSphere Application Servers fail to start with the message:
Could not reserve enough space for object heap

Cause

Operating system does not have sufficient physical memory + swap space to start a new process

Environment

Linux, Solaris, HPUX, AIX, Windows

Diagnosing The Problem

After adding new servers, all of the servers cannot be started at the same time. This issue may also arise if other processes or applications are added to a server. In which case the processes will start until the problem arises.

For the WebSphere Application Servers:

The startserver log may show

ADMU011E unable to start server with reason PROC0009E -operating system could not allocate free memory

There may also be messages in the verbose garbage collection log (native_stderr.log for Linux/AIX/Widows native_stdout.log for Solaris/HPUX) :

Error occurred during initialization of VM Could not reserve enough space for object heap



Resolving The Problem

These messages may arise from more than one root cause

1) The physical memory on the system is not sufficient to contain all the running processes. This will be shown by system monitoring commands/tools such as PerfMon on Windows, vmstat or top on AIX, Linux, Solaris. In this case the remedy is to add physical memory or restrict the number of running processes.

2) For some Operating Systems, there may not be sufficient swap area to back up running processes. This will usually be seen when the system is not under paging/swapping stress but the swap area is not equal to the memory in use or calculated to be needed by the kernel. This condition can be alleviated by having the system administrators add swap space to at least equal the physical memory. The systems should be closely monitored for paging by the System administrators in this case.

3) There may be system limits on the memory that can be allocated by a process or user. In these cases the System Administrators will need to update the system limits (e.g. ulimits for Linux/AIX/...) or make the appropriate changes to the quotas in place.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5.5;8.5;8.0;7.0;6.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21668580