Troubleshooting
Problem
The error "Unable to establish connection with host. SSL system call error" occurs when recording a TN3270 session in Rational Performance Tester (RPT) with the BlueZone client.
Symptom
The BlueZone client is a third party TN3270 client from Rocket Software. When doing a TN3270 recording in RPT using the BlueZone client, this error occurs:
Unable to establish connection with host. SSL system call error.
Here is a screen capture of the error:
Cause
The BlueZone client is configured to use Implicit SSL/TLS instead of Explicit SSL/TLS.
Resolving The Problem
1. Start the BlueZone session manager
2. Click on the session used during the TN3270 recording
3. From the BlueZone Mainframe Display choose the menu option Session > Configure....
4. In the Session Configuration, go to the Connection section. Highlight the TN3270/TN3270E connection type and then click Properties...
5. Click the Security tab
6. Change Security Options to use Explicit SSL/TLS
7. Click OK
8. Start a new TN3270 recording as a Managed Application using socket protocol
9. The session starts and you are able to do the TN3270 recording
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Document Information
Modified date:
16 June 2018
UID
swg21663908