Question & Answer
Question
How does EarliestScheduleDate attribute affect Scheduing Rules in IBM Sterling Order Management System?
Cause
You want to check if the AVAILABLE_DATE is set to EarliestScheduleDate.
Answer
The EarliestScheduleDate attribute in the input XML corresponds to the current time + the number of hours that the order should be delayed for.
Hence if the current time as 2014-01-03T10:00 and you place a order using createOrder API with
EarliestScheduleDate set to 2014-01-03T19:00, the order will be delayed by 10:00 + 9 =19 hours.
However, with scheduling agent running and the Retry Intervals set to 5 hours, If the EarliestScheduleDate is less the Retry Interval, The AVAILABLE_DATE of the order will be set to EarliestScheduleDate.
For example:
Input.xml of CreateOrder API with EarliestScheduleDate as 2014-01-03T19:00:00-05:00.
---------------------
<Order DocumentType="0001" EnterpriseCode="DEFAULT" >
<OrderLines>
<OrderLine ItemGroupCode="PROD" OrderedQty="1" ShipNode="" EarliestScheduleDate="2014-01-03T19:00:00-05:00">
<Item ItemID="Item" UnitOfMeasure="EACH" />
</OrderLine>
</OrderLines>
<PersonInfoBillTo Country="US" />
</Order>
---------------------
Upon order creation, the AVAILABLE_DATE is set to current time.
With the scheduling agent running, order will not get scheduled first time and agent will set AVAILABLE_DATE to 2014-01-03T19:00:00-05:00 (EarliestScheduleDate). Order will remain in created status. Schedule agent will pick this order again on or after 2014-01-03T19:00:00-05:00 and schedule it (depending on the availability).
NOTE: The Default Retry Interval for scheduling is set to 5 hours. AVAILABLE_DATE will be set to current time+5 hours only when scheduler fails (order is backordered or exception in scheduling) to schedule the order during the first attempt or else for every fresh order the AVAILABLE_DATE is set to current time.
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Document Information
Modified date:
10 May 2022
UID
swg21662035