IBM Support

Start Rational DOORS results in error "Entry point not found"

Troubleshooting


Problem

Attempts to start IBM Rational DOORS client results in error "The procedure entry point?qss_convertWidecharToUTF8@YAXPADPB_WH@Z could not be located in the dynamic link library general_library.dll".

Symptom


Attempts to start DOORS client results in error "Entry point not found"

The procedure entry point?qss_convertWidecharToUTF8@@YAXPADPB_WH@Z could not be located in the dynamic link library general_library.dll.


Cause

You successfully apply a Rational DOORS patch, but now the client fails to load with a procedure entry point error.

Diagnosing The Problem

Verify your Rational DOORS installation version for recently applied patches.
Some patches, or hotfixes, are meant for specific product versions.
This error could result if you apply a software patch to the wrong product version. For example you could see such an error if you applied a patch to your DOORS 9.5.2 installation but the patch is for DOORS version 9.5.1.2

Resolving The Problem

This type of error message indicates a problem with one of your installed program files. You can attempt to correct the issue by running the product installer and selecting repair. If the problem persists you need to uninstall the Rational DOORS client and install the necessary version; then, apply the related product patch.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3;9.3.0.1;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.4;9.4.0.1;9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.1.2;9.5.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21661699