Troubleshooting
Problem
Installation of the GIM agent on a database server fails with a central_logger.log error message. .
Symptom
The following error is shown after the license agreement is accepted.
Installing modules ....
cp: cannot stat `/usr/local/GIM/modules/central_logger.log': No such file or directory
Installation failed
Cause
The GIM install script tries to establish secure communication with the Guardium server and aborts if it cannot.
Diagnosing The Problem
The GIM files are created under <GIMinstallDir>/modules/GIM/current but central_logger.log was not created.
The entry for GIM appears in /etc/inittab ...
gim:2345:respawn:/usr/local/bin/perl /usr/local/guardium/modules/GIM/8.2.00_r36821_1-1327530994/gim_client.pl |
... but the following line for the supervisor is missing:
gsvr:2345:respawn:/usr/local/guardium/modules/perl /usr/local/guardium/modules/ SUPERVISOR/8.2.00_r36821_1-1327530994/guard_supervisor |
Resolving The Problem
Use telnet to ensure a clean connection on port 8081 both ways between the DB server and the Guardium machine specified by --sqlGuardIP on the install command line.
Correct any network or firewall related issues, then uninstall GIM and reinstall.
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21650449