IBM Support

Web application is not accessible on Liberty servers when running on Windows operating systems

Troubleshooting


Problem

In WebSphere Application Server Version 8.5.5.1, if a Liberty server is started after a Windows machine has been rebooted, then the web application that is hosted on that server might not be accessible.

Symptom

For V8.5.5.1, if a Liberty server is started after a Windows machine has been rebooted, the Liberty logs show that the web application that is hosted on that server is available. The message in the log file is similar to the following message:

CWWKT0016I: Web application available (default_host): http://<host>:<port>/xxx.

However, when you try to access the web application using a browser, you might get an HTTP 404 (Not Found) error message because the application is not accessible using the specified port.

Cause

This error might be caused by a port conflict between the application server and the Liberty server.

This port conflict can occur when all of the following conditions exist:

  • Both Liberty and WebSphere Application Server are installed on the same system.
  • The application server is installed as a Windows service.
  • The Liberty server port is the same as the application server port.
  • The WebSphere Application Server server is started, and afterwards, the Liberty server is started.

Resolving The Problem

This port conflict can be resolved by taking one of the following recommended actions:

  1. Change the Liberty server port to a port that is different from the port that is used by the application server.
  2. Stop the WebSphere Application Server Windows service.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"HTTP Transport","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.5","Edition":"Liberty","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21648606