IBM Support

How to configure Agent Server to trigger in Coordinated Universal Time

Question & Answer


Question

How do you configure Agent Server to trigger in Coordinated Universal Time(UTC) in IBM Sterling Order Management?

Cause

Database server and application are hosted on different time zone.

Answer

Steps to configure:

  1. Go to <Sterling Order Management  installation directory>/bin folder.

  2. Open AgentServer.sh ( for Linux) or Open AgentServer.cmd (for Windows) for editing.

  3. Add -Duser.timezone=UTC to the JVM argument as shown below:

    set AGENT_JAVA_OPTS= -Dvendor=shell -DvendorFile=C:/IBMSterling/SSFF/properties/servers.properties -DCACHE_PS=true -DDISABLE_DS_EXTENSIONS=Y -Duser.timezone=UTC

  4. Save and run the file to get the changes.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Maintenance","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 May 2022

UID

swg21648396