Troubleshooting
Problem
Attempts to generate Out-Of-Box (OOB) reports using IBM Rational License Key Server (RLKS) Administration and Reporting Tool results in a subset of license usage information.
Symptom
Generating OOB reports using RLKS Administration and Reporting Tool results in a subset of license usage information where you have selected one or more of the following:
- A large number of products
- A high frequency (such as Hourly)
- A large duration (such as 6 months)
image
Cause
When a large volume of data is returned by the database, you browser cannot display chart images with such large volumes; hence, the charts contain only a subset of information to allow them to display properly in the browser.
The following chart-based OOB reports may display a subset of information when handling such large volumes of data:
- Peak Usage
- Peak Denial
- Available Licenses
In addition, the database also has a limitation of returning only 15,000 records by default. This limit affects all OOB reports. When this limit is reached, all OOB reports display a subset of license usage information.
Resolving The Problem
The RLKS Administration and Reporting Tool attempts to display a maximum of approximately 300 odd records in the chart so that the image of the chart can be rendered by the browser.
The RLKS Administration and Reporting Tool also displays a message indicating that the report shows a subset of information and that the user should try another set of parameters to improve the coverage of data in the chart.
WORKAROUNDS:
- OPTION 1: Export the OOB report into a data format of your choice.
The exported data will represent the license usage data according to all the selected user parameters in the report.
- OPTION 2: Select a fewer number of products, a lower frequency and/or a smaller duration and re-run the report.
- OPTION 3: Increase the Query Result Set Limit for the Data Store
How to reset Query Result Set Limit for the Data Store:
- Enter http://
:4380/lqe in a browser - Provide Administrator credentials for login
- Navigate to Administration > Query Service
- Click the Edit link at the top right corner of the panel
- Modify the value in the Query Result Set Limit field to a higher value
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21647564