Troubleshooting
Problem
When I try to run fileserver command on the IBM InfoSphere Guardium CLI prompt I get the error: Fileserver is already running
Cause
This is an expected behavior. It is likely that another user is already running fileserver on this appliance and only one fileserver is allowed to run at a time.
Resolving The Problem
Verify that there is no other user is logged in as CLI on this appliance and is running fileserver.
Versions up to at least v10.1 will have a diag utility that can be used to perform certain actions.
If you wish to work around the problem by killing off the current fileserver command that is apparently in use - then you can follow these steps:-
1) Login to CLI on the Guardium appliance
2) Type diag to launch the diag utility. Your screen should look like this:
![](/support/pages/system/files/support/swg/sectech.nsf/0/852577ca0009093385257bc00067b61c/Content/0.390.gif)
3) Select the "Perform Maintenance Actions" - Use the down arrow key or just press 4 on your keyboard to choose the 4th option and press Enter key on your Keyboard:
4) Choose "Clean disk space" - option 3 and press Enter:
- ( * Note - For circumstances other than this fileserver problem - you should only use this "Clean disk space" option having previously consulted IBM Security Guardium Technical Support )
5) From the list of directories choose /var/tmp and press Enter:
6) In the Search string textbox, type fileserver_started and press Enter:
7) The following file will be listed - press Enter key on the < OK >
![](/support/pages/system/files/support/swg/sectech.nsf/0/852577ca0009093385257bc00067b61c/Content/0.1718.gif)
8) Then Confirm removal of the file - choose Yes
9) . You can ignore the message that recommends rebooting the appliance for the changes to take effect. - press Enter key on the < OK > at this point .
10) To exit diag utility, use the arrow keys to choose Cancel and press Enter on each screen until you're taken back to CLI
You should now be able to use the fileserver command
If you still have issues please contact Guardium Support for further assistance.
Note to IBM Technical Support Engineers
If required please look at the "Internal Use Only" section of this technote via Wellspring or the DCF database to follow the resolution steps
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Document Information
Modified date:
16 June 2018
UID
swg21646294