IBM Support

Starting Rational DOORS database service results in "The service did not respond" error

Troubleshooting


Problem

Attempts to start IBM Rational DOORS database service results in the error "The service did not respond".

Symptom

The following error message will be displayed in the Event viewer:

Failed to load crypt dll.

The full error message is as follows:

Windows could not start the DOORS DB Server 9.5 service on Local Computer.

Error 1053: The service did not respond to the start or control request in a timely fashion.

Cause

The issue is caused as the existing crypt.dll (version 9.3.0) located in <DOORSHome>/bin folder after installing the DOORS Server, is upgraded to the newer version 9.5.1.1 when the DOORS client is installed.
The older version of the Server is not compatible with the new version of the dll file.

Resolving The Problem

The crypt.dll file has been upgraded in Rational DOORS Fix Pack 1 (9.5.1.1) for 9.5.1 (client and server) to address security vulnerability.

WORKAROUNDS:

  • Install the DOORS Client and Server in different directories on the same machine. This will ensure that the Client and Server use their respective crypt.dll

    OR

  • Replace the updated crypt.dll (version 9.5.1.1) in the <DOORSHome>/bin folder with the older version of the file (version 9.3.0.0) which was backed up earlier.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3;9.3.0.1;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.4;9.4.0.1;9.5;9.5.0.1;9.5.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21643440