Troubleshooting
Problem
With IBM Business Process Manager, duplicate snapshot installation requests are sent to the Process Server from the Process Center after a 1 minute delay. IBM HTTP Server is used as a web server for the Process Center console. This scenario leads to an additional load on the system, delays, and sometimes installation failures.
Symptom
Duplicate requests are sent to the Process Center for actions that take longer than 1 minute.
These requests might include items like:
- Snapshot install
- Snapshot import/export
- Snapshot archive
In the SystemOut.log file for the Process Center, there are multiple log messages for the same action 1 minute apart. You see messages similar to the following text:
CWLLG0146I: Beginning export install for snapshot
Cause
The default settings for the HTTP Server retry a POST request after 1 minute if a response is not received. Various functions of the Process Center console use HTTP POST requests. Many of these functions can take longer than 1 minute like a snapshot install, import, or export.. IBM Business Process Manager does not support sending multiple POST requests for the same Process Center action.
Resolving The Problem
Tune the HTTP settings to avoid the POST retry requests.
The following documents describe the HTTP configuration parameters:
- Recommended values for web server plug-in config
- How do the properties ServerIOTimeout and PostBufferSize affect plug-in behavior?
As mentioned in this document, there are two things that can affect the specific retry behavior. Setting the PostBufferSize property to 0 disables the retries for POST requests. The client gets a 500 error after the HTTP server time out even though the previous POST request might still be running on the destination server. The ServerIOTimeout setting determines what the HTTP server time out is for requests.
Related Information
Product Synonym
BPM
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Document Information
Modified date:
15 June 2018
UID
swg21626369