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IBM InfoSphere Guardium CAS not working with Java version 1.7 on windows

Troubleshooting


Problem

IBM InfoSphere Guardium CAS not working with Java version 1.7 on windows but it works with older Java versions.

Cause

msvcr100.dll is missing from <GUARDIUM STAP directory>\cas\bin\ (ie. C:\Program Files (x86)\Guardium\GUARDIUM_STAP\cas\bin\).

Resolving The Problem


1- find the path where Java 1.7 is installed on your system (ie. C:\Program Files (x86)\Java\jre7\bin\ but it may be different on your system).


2- find the location of the library jvm.dll within the java path found in the previous step (ie. C:\Program Files (x86)\Java\jre7\bin\jvm.dll or C:\Program Files (x86)\Java\jre7\bin\server\jvm.dll but may be in different location under the java installation directory). Copy the complete path.


3- Edit the cas.cfg file in <CAS directory>\conf directory ( ie. C:\Program Files (x86)\GUARDIUM_STAP\cas\conf\cas.cfg)


4- Find the line (usually at the end of the file) corresponding to the JVM, ie. it will look similar to this:

;JVM=c:\program files\java\jre1_2_3\bin\client\jvm.dll

and do this:

a) set JVM to the path of the libray jvm.dll that you found in step 2-
b) uncomment the line if commented (ie. take the semicolon out from the beginning of the line)

For example, if the line looks like this:

;JVM=c:\program files\java\jre1_2_3\bin\client\jvm.dll

you would change it to something like this, assuming C:\Program Files (x86)\Java\jre7\bin\server\jvm.dll is the path to the jvm.dll library:

JVM=C:\Program Files (x86)\Java\jre7\bin\server\jvm.dll


5- Copy 'msvcr100.dll' from the bin folder in your java 7 installation directory to your <CAS directory>\bin folder (ie. copy C:\Program Files (x86)\Java\jre7\bin\msvcr100.dll to C:\Program Files (x86)\Guardium\GUARDIUM_STAP\cas\bin\msvcr100.dll) .

This is only needed for Java version 1.7. For older versions of java this step is not needed. The reason is that in version 7 Java the jvm.dll has a dependency on this msvcr100.dll which was not the case with older java versions.


6- Restart the CAS (Change Audit System) sevrice in control Panel / Administrative Tools / Services

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Document Information

Modified date:
16 June 2018

UID

swg21626214