IBM Support

XQE-JDB-0004 error testing a JDBC connection for Microsoft SQLServer

Question & Answer


Question

When testing a JDBC connection to Microsoft SQL Server 2005 / 2008 / 2012 you receive the error XQE-JDB-0004 A problem occurred finding the driver class "com.microsoft.sqlserver.jdbc.SQLServerDriver".

Cause

The JDBC connector is missing or not properly installed for Cognos

Answer

You may need to download the .JAR files from Microsoft download center site:
http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=11774
or search for "Microsoft JDBC Driver for SQL Server" via your favorite search engine.
Follow the Microsoft instructions to download and install.

Once done, locate the .JAR files sqljdbc4.jar and sqljdbc.jar then copy:
- sqljdbc.jar(SQLServer 2005)
- sqljdbc4.jar (SQL Server 2008 & 2012)
to <Install_Cognos>\v5dataserver\lib
and <Install_Cognos>\webapps\p2pd\WEB-INF\lib

You need to stop/start Cognos to load the jars on startup.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Administration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21623909