Troubleshooting
Problem
An IBM Spectrum Protect database backup initiated using the command BACKUP DB fails with an error of ANR2981E with a sqlcode -2033 sqlerrmc 106.
Symptom
Tivoli Storage Manager backup fails with the following messages in the activity log:
- ANR2280I Full database backup started as process 2.
ANR2981E Database backup terminated due to environment or setup issue related to file access - DB2 sqlcode -2033 sqlerrmc 106.
ANR0985I Process 2 for Database Backup running in the BACKGROUND completed with completion state FAILURE at 12:49:43.
The corresponding messages found in the DB2 log file, db2diag.log, are as follows:
- 2012-11-12-12.49.43.390086-300 E621219A970 LEVEL: Severe
PID : 17891388 TID : 145793 PROC : db2sysc 0
INSTANCE: tsminst1 NODE : 000 DB : TSMDB1
APPHDL : 0-1505 APPID: *LOCAL.tsminst1.121112175917
AUTHID : TSMINST1
EDUID : 145793 EDUNAME: db2agent (TSMDB1) 0
FUNCTION: DB2 UDB, database utilities, sqlubHandleTSMError, probe:1252
MESSAGE : SQL2033N An error occurred while accessing TSM during the processing
of a database utility. TSM reason code: "".
DATA #1 : SQLCA, PD_DB2_TYPE_SQLCA, 136 bytes
sqlcaid : SQLCA sqlcabc: 136 sqlcode: -2033 sqlerrml: 3
sqlerrmc: 106
sqlerrp : sqlubHan
sqlerrd : (1) 0x00000000 (2) 0x00000000 (3) 0x00000000
(4) 0x00000000 (5) 0x00000000 (6) 0x00000000
sqlwarn : (1) (2) (3) (4) (5) (6)
(7) (8) (9) (10) (11)
sqlstate:
2012-11-12-12.49.43.654111-300 E622190A348 LEVEL: Error
PID : 7995608 TID : 1 PROC : db2vend
INSTANCE: tsminst1 NODE : 000
EDUID : 1
FUNCTION: DB2 UDB, database utilities, sqluvdel, probe:1369
DATA #1 : TSM RC, PD_DB2_TYPE_TSM_RC, 4 bytes
TSM RC=0x0000006A=106 -- see TSM API Reference for meaning.
2012-11-12-12.49.43.654982-300 I622539A942 LEVEL: Error
PID : 17891388 TID : 145793 PROC : db2sysc 0
INSTANCE: tsminst1 NODE : 000 DB : TSMDB1
APPHDL : 0-1505 APPID: *LOCAL.tsminst1.121112175917
AUTHID : TSMINST1
EDUID : 145793 EDUNAME: db2agent (TSMDB1) 0
FUNCTION: DB2 UDB, database utilities, sqlubDeleteVendorImage, probe:558
MESSAGE : SQL2062N An error occurred while accessing media "". Reason code:
"".
DATA #1 : String, 27 bytes
Error returned by sqluvdel.
DATA #2 : Vendor RC, PD_DB2_TYPE_VENDOR_RC, 4 bytes
Vendor RC=0x0000001A=26 -- see DB2 API Guide for meaning.
DATA #3 : Hexdump, 48 bytes
0x0A00060137109070 : 0000 006A 3133 3639 2031 3036 0000 0000 ...j1369 106....
0x0A00060137109080 : 0000 0000 0000 0000 0000 0000 0000 0000 ................
0x0A00060137109090 : 0000 0000 0000 0000 0000 0000 0000 0000 ................
Cause
There are numerous triggers of the sqlcode -2033 with a sqlerrmc 106, which simply reflects that access is denied to a required component. This document discusses a trigger where the DSMI_* environment variables are not properly defined within the userprofile script. This script can be found in the following locations:
- <instance user home directory>/sqllib/userprofile
- This files location is determined by the setting of a DB2 instance registry variable, DB2_VENDOR_INI. The name is traditionally tsmdbmgr.env instead of userprofile.
The following additional documents have been published to address other triggers of the error code:
http://www-01.ibm.com/support/docview.wss?uid=swg21430114
http://www-01.ibm.com/support/docview.wss?uid=swg21385178
Resolving The Problem
Verify that the userprofile script is setup properly. The correct values that need to be within the script can be found below in the example text:
- export DSMI_CONFIG=/home/tsminst1/tsminst1/tsmdbmgr.opt
export DSMI_DIR=/usr/tivoli/tsm/client/api/bin64
export DSMI_LOG=/home/tsminst1/tsminst1
Verify that the tsmdbmgr.env file is setup properly. The correct values that need to be within the script can be found below in the example text:
DSMI_CONFIG=C:\Progra~1\Tivoli\TSM\Server1\tsmdbmgr.opt
DSMI_LOG=C:\Progra~1\Tivoli\TSM\Server1
Once the changes have been made, re-issue the BACKUP DB command.
Related Information
Product Synonym
TSM ITSM ADSM IBM Spectrum Protect
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21623149