IBM Support

Error messages in Active Directory Agent logs

Troubleshooting


Problem

Active Directory Agent reports "PdhValidatePath failed for [\Database(lsass)\Cache % Hit] c0000bb9" error message in log files.

Symptom


(50235319.0628-1C48:k3zutil.cpp,735,"CKUtil::DisplayPDHError") Exit
(50235319.0629-1C48:k3zpdh.cpp,698,"AddCounters") PdhValidatePath failed for [\Database(lsass)\Cache % Hit] c0000bb9
(50235319.062A-1C48:k3zutil.cpp,716,"CKUtil::DisplayPDHError") Entry
(50235319.062B-1C48:k3zutil.cpp,728,"CKUtil::DisplayPDHError") PDH error message text <The specified counter could not be found.

Cause

These error are reported in a log files because this performance counter is not present on windows 2008 R2 servers.

Resolving The Problem

This would not affect the monitoring of AD server as Windows 2008 R2 uses a different performance counter [Database\Database Cache % Hit] to collect this data.

For example as in the log:

(50235319.0647-1C48:k3zpdh.cpp,721,"AddCounters") Adding (13)[Database\Database Cache % Hit]

[{"Product":{"code":"SSDKXQ","label":"Tivoli Composite Application Manager for Microsoft Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Active Directory Agent - 5724C71AO","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.2.2;6.2.3;6.3.0;6.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21609969