Troubleshooting
Problem
On a 64-bit Linux x86 operating system, you install a 64-bit version of IBM Installation Manager. You then access media like an Electronic Software Download (ESD) or a product disk that contains a 32-bit Installation Manager from an earlier version. When the later version of Installation Manager is detected, an attempt is made to start this version. The start of the 64-bit version of Installation Manager fails with the error message: "An error has occurred. See the log file /opt/IBM/InstallationManager/eclipse/configuration/log_file_name.log."
Symptom
In the log file, you see messages similar to the following entries:
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_64_3.6.0.v3650b [14] was not resolved.
!SUBENTRY 2 org.eclipse.swt.gtk.linux.x86_64 2 0
2011-04-19 14:58:39.748
!MESSAGE Platform filter did not match:
(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-04-19 14:58:39.748
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.0.v20100503
[90] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86_64
2 0 2011-04-1914:58:39.748
!MESSAGE Platform filter did not match:
(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))
Cause
Installation Manager versions 1.0.0.x, and 1.3.1 - 1.4.2 cannot start a 64-bit version of Installation Manager.
Resolving The Problem
This issue is fixed for Installation Manager versions 1.4.3 and later.
For Installation Manager versions 1.4.2 and earlier, to workaround this issue:
1. Download the latest 32-bit version of Installation Manager, see Installation Manager and Packaging Utility download links.
2. Install the 32-bit version of Installation Manager by using the -reinstallIM
option, see the Installation Manager Information Center.
3. Run the earlier 32-bit version of Installation Manager from the media that you are using. The installed 32-bit version of Installation Manager starts.
Was this topic helpful?
Document Information
Modified date:
25 October 2021
UID
swg21609056