Troubleshooting
Problem
Customer upgraded from 7.1.x to version 7.5 and now they can't authenticate their IMAP email listener configuration.
Symptom
After implementing the java mail debug property as outlined in Lifting the Hood on JavaMail Communications document in the developerworks site: See link below.
The following error appears in the logs.
[ERROR] [MXServer] [CID-CRON-54239] Encountered error processing e-mails from mail server.
javax.mail.AuthenticationFailedException: AUTHENTICATE failed.
at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:474)
at javax.mail.Service.connect(Service.java:275)
at javax.mail.Service.connect(Service.java:156)
at javax.mail.Service.connect(Service.java:105)
at psdi.common.emailstner.EmailListnerTask.readMessagesFromMailServer(EmailListnerTask.java:628)
at psdi.common.emailstner.EmailListnerTask.performTask(EmailListnerTask.java:266)
at psdi.common.emailstner.EmailListnerCron.cronAction(EmailListnerCron.java:49)
at psdi.server.CronTaskManager.callCronMethod(CronTaskManager.java:1569)
at psdi.server.CronTaskManager.access$400(CronTaskManager.java:87)
at psdi.server.CronTaskManager$CronThread.run(CronTaskManager.java:2135)
Cause
In latest versions of Websphere 7 vs Websphere 6 the JavaMail API changed.
Resolving The Problem
To resolve the problem a new System Property was added. The new property
mail.imap.auth.plain.disable=true was added and along with a restart of the application server, the problem is resolved. The Live Refresh does appear to be functional, but in this case a Server Restart was required.
Related Information
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21606842