IBM Support

CTE0183E Error occurred using shared system resources.

Troubleshooting


Problem

When using DB2 Net Search Extender, start or stop of db2text commands may fail with CTE0183 error.

Symptom

Following error will be thrown in this case:

/home/db2inst1 : db2text start
CTE0183E Error occurred using shared system resources.

home/db2inst1 : db2text stop
CTE0183E Error occurred using shared system resources.


db2diag.log file may show similar error messages like below:

2012-05-07-14.47.04.002516-240 I25057798A379 LEVEL: Error
PID : 946590 TID : 1 PROC : ctecsdem
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, Net Search Extender,
CteDemonResource::openScheduleCtrlSemaph, probe:1
MESSAGE : CTE reason
DATA #1 : Hexdump, 4 bytes
0x0FFFFFFFFFFFB678 : 0000 00B7 ....

2012-05-07-14.47.04.003102-240 I25058178A272 LEVEL: Error
PID : 946590 TID : 1 PROC : ctecsdem
INSTANCE: db2inst1 NODE : 000
MESSAGE : Message
DATA #1 : String, 54 bytes
CTE0183 Error occurred using shared system resources.

Cause

Following could be the reasons:

- There exists some files under /tmp directory that are owned by instance owner.

- There are some IPCS resources that have a key starting with 0xcb and 0xce which belong to the instance owner.

- No write permissions on /tmp directory for instance owner and fenced user.

Diagnosing The Problem

1) Check if there exists following files in /tmp

      UPPERCASE_INSTANCE_NAME.TEXT.0000.LATCH

      UPPERCASE_INSTANCE_NAME.SCHEDULER.LATCH

      UPPERCASE_INSTANCE_NAME.DEMON.SEM

      UPPERCASE_INSTANCE_NAME.TEXT.0000

      UPPERCASE_INSTANCE_NAME.CACHE.0000

      UPPERCASE_INSTANCE_NAME.DEMON.MEM

2) Check if there exists IPCS resources that have a key starting with 0xcb and 0xce which belong to the instance owner.



3) Check if /tmp directory has write permission for instance owner and fenced users.

Resolving The Problem

Perform below steps:

1) log on to server as the db2 instance owner

2) try db2text stop

3) db2stop

4) Perform clean up steps as below:

      i) ipclean

      ii) ipcs | grep db2inst

      iii) ipcrm -s <shared memory id> repeat for all shared memory listed

      iv) ipcrm -m <message queue id> repeat for all message queues listed


5.) Use below command to make sure there are no IPCS resources that have a key starting with 0xcb and 0xce which belong to the instance owner. If there are remove them.
      ipcs -a | grep <instance> | grep 0xce

      ipcs -a | grep <instance> | grep 0xcb


7) Remove the following files from /tmp if they are there:

      UPPERCASE_INSTANCE_NAME.TEXT.0000.LATCH

      UPPERCASE_INSTANCE_NAME.SCHEDULER.LATCH

      UPPERCASE_INSTANCE_NAME.DEMON.SEM

      UPPERCASE_INSTANCE_NAME.TEXT.0000

      UPPERCASE_INSTANCE_NAME.CACHE.0000

      UPPERCASE_INSTANCE_NAME.DEMON.MEM


8) ps -ef | grep cte* | grep db2instance_name

9) kill -9 the ctelock process if found.

10) Login or "su -" to root

11) cd <install_path>/instance

12) run "./db2iupdt <instance>"

13) Login or "su -" to the instance owner

14) db2start

15) db2text start

Related Information

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"DB2 Tools - db2diag.log","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.7;9.5;9.1;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21597455