Troubleshooting
Problem
User renders a report to HTML. This works successfully. Afterwards, user decides to view the whole report in PDF mode. An error appears. The report does not appear in PDF format.
Symptom
Adobe Reader
File does not begin with '%PDF-'.http://servername/ibmcognos/cgi-bin/cognosisapi.dll?b_action=.....
Cause
Incompatible settings in Adobe Acrobat/Acrobat Reader X
Environment
Client device has Adobe Acrobat Reader X installed, and is configured to use "Display PDF in browser".
Resolving The Problem
Disable (untick) "Display PDF in browser" in Adobe Acrobat/Acrobat Reader X preferences.
Steps
The steps vary depending on the version of Adobe Reader installed on the client device.
- For more information, see separate IBM Technote #6209640.
The following are based on Adobe Reader 10:
1. Launch Adobe Reader
2. Click "Edit - Preferences"
3. Click on "Internet" section
4. Untick "Display PDF in browser":
Related Information
[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2.1.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
08 September 2020
UID
swg21579802