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DOORS Web Access database explorer keeps loading for a long time after login

Troubleshooting


Problem

IBM Engineering Requirements Management DOORS Web Access database explorer keeps loading for a long time after login

Symptom

Symptom 1:
After login, some projects/folders/modules are displaying loading status for a long time
image 2317
Symptom 2:
Interop log is showing "Shutting down: clear cache and update broker" frequently (for example every 7 seconds)

Tue Jan 7 10:32:37 2020 (69)
Log: 0.2 Level: 8 Shutting down: clear cache and update broker

Tue Jan 7 10:32:44 2020 (53)
Log: 0.2 Level: 8 Shutting down: clear cache and update broker

Tue Jan 7 10:32:51 2020 (56)
Log: 0.2 Level: 8 Shutting down: clear cache and update broker

Cause

The performance of DOORS Web Access server degrades due to that the interop empties its cache too often (for example every 7 seconds).

Interop server empties its cache too often due to that -maxMemory option is not specified in the interop server startup command.

Resolving The Problem

Set -maxMemory in the interop server startup command.

For example,

./doors9 -interop -data $DOORSDATA -brokerHost localhost -brokerPort 61616 -maxMemory 1536 &

Note
On Linux, it is important to set the maxMemory option

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Component":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

ibm11918761