IBM Support

Orders stuck in Schedule or Release Agent

Troubleshooting


Problem

Orders stuck in Schedule or Release Agent

Symptom

There are many orders stuck in the yfs_task_q, and the agent does not pick them up at all.

Cause

This problem can happen if the backorder retry time is set to small number. When it's set to a small number, the agent processes an order, for which the items go on backorder, then becuase it went to backorder, it puts it back into the q, and again and again the agent picks it up. So this setting makes performance seem to be very slow.

Environment

Agents-OM 5.0 SP2 Platform
PRODUCT: Distributed Order Management
COMPONENT: Allocate Order
OS: Sun
DATABASE: Oracle 8.1.7
WEB BROWSER: Internet Explorer - 6.0

Resolving The Problem

Increase the backorder retry interval to a reasonable number.

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Historical Number

PRI49330

Document Information

Modified date:
16 June 2018

UID

swg21541579