Troubleshooting
Problem
User launches the main Controller program. User launches Excel-based functionality, but receives error message #1. User launches Excel directly, and receives error #2. If the user attempts to manually add the Excel-link, user receives message #3.
Symptom
Error #1
The Excel-link is not installed
Error #2
Microsoft Excel
The file you are trying to open, 'ControllerXL.xll', is in a different format than specified by the file extension. Verify that the file is not corrupted and is from a trusted source before opening the file. Do you want to open the file now?
[Yes] [No] [Help]
Error #3
Microsoft Excel
'C:\Program Files (x86)\Cognos\ccr\ControllerXL.xll' is not a valid add-in.
[OK]
Cause
Error #1 is a generic message. There are many different potential causes for this.
- TIP: For more examples, see separate IBM Technote #1396195.
This IBM Technote specifically relates to the scenario where Error #2 is also seen. In this scenario, the problem is caused by the fact that Microsoft Office 2010 64-bit does not support 32-bit Excel add-ins (.XLA files etc.).
- Controller is a 32-bit product, therefore will only integrate with 32-bit applications.
Environment
Controller client running on device which is using Office 2010 64-bit.
Resolving The Problem
Uninstall Office 2010 64-bit from client device. Re-install Office 2010 32-bit instead.
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21504061