Troubleshooting
Problem
When we access Gateway URI through IP address we are re-prompted for login window if the server name is mentioned in IBM Cognos Configuration. Apart from this the reverse can also happen. Meaning that if we access Gateway URI using server name and IP address is mentioned in IBM Cognos configuration we are re-promted for login window
Symptom
User is re prompted to provide log in credentials again even if user has provided right credentials.
Cause
The main cause for this issue is due to DNS entry missing on the DNS server. The network/system administrator should sort it out. Even after having the right DNS entries if you still get the issue you can carry out the resolution steps mentioned in the Tech Note.
Environment
Windows, Unix
Resolving The Problem
The following settings need to be done in Cognos configuration:
1. Under Local Configuration-->Security-->IBM Cognos Application Firewall
Add the domain name under the valid domains or hosts and it should start with a dot.
2. Also Add IP of the Cognos gateway to the valid domains or hosts .
If there are more than 1 gateway, add the IP of all the gateways
For settings in point 1 and 2 refer the screen shot config_settings.jpg attached
3. Actions (Menu) --> Edit Global configuration --> General (Tab) --> Cookie settings (section)
Valid domain should be specified and the path should be left blank.
Please refer the screen shot Global_config_settings.jpg attached
4. Save the configuration and then restart Cognos services.
Apart from the Cognos configuration settings, you have to do the following:
1. Add the gateway IP URL to the trusted sites zone under " Tools-->Internet options-->Security " of the respective browser.
eg. http://<IP>
2. You may want to add Cognos server IP and Server name to the host file of the OS on all machines from where Cognos is accessed.
Location for the host file is:
Windows: C:\Windows\system32\drivers\etc\
Unix: /etc/hosts
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Document Information
Modified date:
15 June 2018
UID
swg21502935