IBM Support

On Windows operating systems, IBM Installation Manager cannot detect Edge Components V8 processes that are already running

Troubleshooting


Problem

If some processes for Edge Components are active when you use IBM Installation Manager to uninstall the product, Installation Manager might not be able to remove all the necessary files.

Symptom

If this problem occurs, you see one of the following error messages:

  • For Caching Proxy:

    Error uninstalling.

    Click Details, and you will see the following message:

    Deleting files from [Caching_Proxy_Location]
    Failed to delete D:\Program Files (x86)\IBM\edge\cachingproxy\cp\msg\config_en_US.res
    ...


    The files that are listed in the error message depend on the processes that are running.

  • For Load Balancer for IPv4:

    Uninstallation Failed

    Click Details, and you will see the following message:

    Deleting files from [Load_Balancer_Installation_Location]
    Error unzipping C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager\adapters\native\Load Balancer for IPv4\backupDirs\9\0.zip:Can not delete file "<some file>.dll"
    ...


    The files that are listed in the error message depend on the processes that are running.

Cause

On some Windows operating systems, Installation Manager is not able to detect Edge Components processes that are running on the system.

This problem typically occurs if any of directories in the installation path have more than eight characters in the name.

Resolving The Problem

To resolve this problem, ensure all Edge Components processes are stopped prior to uninstalling the product or installing a new version.

To clean up your system, the locked files and associated services must be removed manually. Complete the following steps:

  1. Navigate to the Services panel to see which processes are remaining for Edge Components, and stop them.

    a. Click Start > Control Panel > Administrative Tools > Services.
    b. Right-click on any services for Edge Components, and select Stop.

  2. Remove the services. Open a command prompt and type the following command:

    sc delete service_name

    The service_name variable is the name of the Edge Components service that you want to remove.

  3. After you remove all of the services for Edge Components, restart your system.
  4. Manually remove the Load Balancer and Caching Proxy directories.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Edge Component","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0","Edition":"Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
06 June 2019

UID

swg21501834