Troubleshooting
Problem
When you reinstall IBM Business Process Manager, IBM Integration Designer, or WebSphere Enterprise Service Bus with DB2 Express, the profile creation step fails when it tries to create the databases.
Cause
When you uninstall the product, the uninstallation program removes DB2 Express, but it does not remove the BPMINST directory, which contains the databases.
During reinstallation, the profile creation step fails because the databases already exist.
Resolving The Problem
Delete the BPMINST directory before reinstalling the server images.
Note: The location of the BPMINST directory varies, depending on the operating system that you are using.
- On a Windows operating system, the location of the directory depends on which drive you used for installation. The directory is located at: <drive>:\BPMINST (for example, C:\BPMINST or D:\BPMINST).
- On a Linux operating system, the location of the directory depends on whether you changed the instance user ID.
- If you did not change the ID, the directory is located at: /home/bpminst/bpminst.
- If you changed the ID, the directory is located at: /home/<bpm instance userid>/bpminst.
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Document Information
Modified date:
15 June 2018
UID
swg21501436