IBM Support

Windows might report a crash during the installation of a WebSphere Application Server V6.1 or V7.0 Fix Pack

Troubleshooting


Problem

Under some circumstances, the Windows operating system might report a problem (unexpected termination or crash) with a "java.exe" process while installing or uninstalling a WebSphere Application Server V6.1 or V7.0 Fix Pack using the UpdateInstaller utility.

Symptom

Under some circumstances, a child Java process run by the UpdateInstaller V7.0 utility might crash while applying a Fix Pack to WebSphere Application Server V7.0 or V6.1. This will occur when the UpdateInstaller is in the stage of "Running Configuration Actions" during a fix pack installation or uninstallation.

The UpdateInstaller utility itself does not crash, and the Fix Pack installation will be reported as successful. The crashing java.exe process becomes apparent because Windows displays a dialog box which indicates that the process named "java.exe" has experienced a problem and the process is terminated.

Cause

On Windows XP and Windows 2003, the UpdateInstaller utility is started using a batch file called "update.bat". This batch file temporarily modifies the system's PATH environment variable in order to start the UpdateInstaller. However, the PATH is set incorrectly.

Due to this incorrect setting, certain WebSphere Application Server utilities run by the UpdateInstaller will incorrectly load Java libraries from UpdateInstaller's copy of Java, instead of loading libraries from WebSphere Application Server's copy of Java. Loading libraries in this incorrect manner can cause the WebSphere utility's jave.exe process to crash, because it has loaded incompatible libraries.

Specifically, the crash occurs when running the "clearOSGiCache" script, which is typically the last configuration script run while installing a Fix Pack.

Environment

This issue is most likely to occur on specific editions of the Windows operating system: Windows XP and Windows 2003.

When UpdateInstaller is installed on Windows Vista, Windows 7, Windows 2008, or Windows 2008 R2, it is installed with a file named "update.exe". The "update.exe" file is used to start the UpdateInstaller on those editions of Windows instead of "update.bat". The "update.exe" file does not have this issue, so this crash issue should not occur on Windows Vista, Windows 7, Windows 2008, Windows 2008 R2, or later editions of the Windows operating system.

Resolving The Problem

Workaround to prevent crash
Until a permanent fix is available in a newer version of Update Installer, this workaround will suppress the crash:

  1. Locate the update.bat file in the main directory of the installed UpdateInstaller.

  2. Make a backup copy of the update.bat file.

  3. Open the update.bat file in a text editor.

  4. Search for the line which begins with this text, which should appear on line 93:

    set PATH=%updiJAVAHOME%\bin

    Change that line to the following text:

    rem set PATH=%updiJAVAHOME%\bin

  5. Search for the line which begins with this text, which should appear on line 98:

    start /B javaw.exe

    Change the beginning of that line to this text:

    start /B "" "%updiJAVAHOME%\bin\javaw.exe"

    (Be sure that the remainder of the line is preserved. Also be sure to include all of the double quotation mark characters as shown above.)

  6. Search for the line which begins with this text, which should appear on line 103:

    java.exe

    Change the beginning of that line to this text:

    "%updiJAVAHOME%\bin\java.exe"

    (Be sure that the remainder of the line is preserved. Also be sure to include all of the double quotation mark characters as shown above.)

  7. Save the edited update.bat file.

  8. Done. Proceed to use the UpdateInstaller normally. A crash message should no longer appear when installing fix packs.


Advice for situations where a crash has occurred
If this crash occurs while installing or uninstalling a fix pack, then the WebSphere Application Server OSGi cache may not have been properly cleared. You do not need to reinstall the affected Fix Pack to correct this. Instead, follow these steps to correct the issue:
  1. Shut down all processes associated with the WebSphere Application Server installation instance which was updated with the Fix Pack that encountered the crash. Note that this process should not take place while application server processes are running.

  2. Navigate to the install_root/bin directory, and run this command:

    osgicfginit -all

  3. Done. The script which previously had crashed while running Update Installer has now successfully completed.

An APAR is tracking this issue
This issue is tracked by APAR PM39881.

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Document Information

Modified date:
15 June 2018

UID

swg21497901