Question & Answer
Question
How can I avoid common installation problems for WebSphere Integration Developer?
Cause
To avoid common installation problems for WebSphere Integration Developer, use the tips in the following checklist.
Answer
- Check system requirements before you install. To view a list of minimum software and hardware requirements for installing WebSphere Integration Developer, see the System Requirement list and select your product version.
- Confirm that your user ID meets the required access privileges for installing WebSphere Integration Developer.
- For the Windows operating system, use the local system administrator ID to install WebSphere Integration Developer. Do not use the domain ID.
- Ensure that your system has enough disk space for WebSphere Integration Developer.
- For a default installation, you need at least 3.3 GB of available disk space, including the temporary disk space required during installation.
- For a full installation, you need at least 7.5 GB of available disk space, including the temporary disk space required during installation.
See User privileges requirements.
To view the amount of free disk space, check both the target drive and the %TEMP% folder.
- Check installation requirements for other products.
If you have installed or are planning to install other Eclipse-based products (for example, IBM Rational Application Developer for WebSphere Software, IBM Rational Software Architect for WebSphere Software, or WebSphere Business Modeler), see Coexisting installations of WebSphere Business Integration tools for installation requirements for the other products.
- Ensure that no Java processes are running.
Some instances of the test environment server might be running in the background. Ensure that all servers are stopped before you install WebSphere Integration Developer.
- Turn off antivirus programs.
Some antivirus programs might interfere with the installation by preventing the installer from accessing the disk. Disable antivirus programs before you install WebSphere Integration Developer. For more information about problems caused by antivirus programs during installation, see Exceptions thrown during installation of WebSphere Integration Developer and Slow installation process for WebSphere Integration Developer. For more troubleshooting information, see Troubleshooting the installation process.
- Turn off disk encryption programs.
Some disk encryption programs might interfere with the installation by preventing the installer from accessing the disk. Disable disk encryption programs before you install WebSphere Integration Developer.
- Install or update only one product at a time.
- Use the latest version of the IBM Installation Manager.
- If you plan to install WebSphere Integration Developer online, you do not need to check for the latest version of the IBM Installation Manager. When you install online, you receive the latest version of the IBM Installation Manager automatically.
- If you plan to install WebSphere Integration Developer online, check your network connections.
- Extract the installation images for WebSphere Integration Developer from Passport Advantage.
- For complete instructions for V7.0, see Download WebSphere Integration Developer V7.0 for Windows.
- Ensure that the target installation path and the server profile path are not too long.
- For Windows XP, the maximum length of the entire file path is 256 characters, including the file name.
- For Windows Vista, the maximum length of the entire file path is 260 characters, including the file name.
- When you install WebSphere Integration Developer on a Microsoft Windows 7, Vista, or other 64-bit Windows operating system, the default installation path will contain (x86).
- Do not click Cancel during the installation, especially if you are installing or updating the runtime test environment.
If you try to install or update more than one product at the same time and one installation does not complete successfully, you might need to uninstall all products. Install or update only one product at a time.
Use a reliable network connection. Do not use a wireless connection that has poor signal quality. If you have a corporate firewall, ensure that the proxy server allows you to connect to the download website.
You must extract the required packages to the same folder on your local system. .
Remove the parentheses around (x86). For more information, see step 10b in Installing with IBM Installation Manager.
If you click Cancel during the installation, it might not complete successfully. In that case, you will need to uninstall WebSphere Integration Developer and then reinstall.
- If you uninstall WebSphere Integration Developer, ensure that the environment is clean before you reinstall.
If you uninstall WebSphere Integration Developer, and the uninstallation does not complete successfully, delete any leftover directories or files before you reinstall. For more information, see Pre-installation verification steps.
- Delete unwanted files in the TEMP directory.
If the TEMP directory contains locked files, the installation might not complete successfully. Before you reinstall WebSphere Integration Developer, deleted unwanted files in the TEMP directory.
- Windows 7 is supported in WebSphere Integration Developer V7.0.0.2 and V6.2.0.3 and later.
WebSphere Integration Developer V.7.0, V7.0.0.1, and releases before V6.2.0.3 do not support Windows 7. For more information, see Detailed hardware and software requirements for WebSphere Integration Developer V7.0.0.2 on Windows.
- Silent installation is supported for WebSphere Integration Developer and the WebSphere Process Server Unit Test Environment (UTE).
- Known issues when update WebSphere Process Server test environment to V7.0.0.3 for WebSphere Integration Developer.
For information on how to install WebSphere Integration Developer and the WebSphere Process Server Unit Test Environment (UTE) silently, see the silent installation FAQ in the WebSphere Integration Developer FAQ document.
When update the WebSphere Process Server test environment to V7.0.0.3 for WebSphere Integration Developer, you may receive prerequisites validation error. To work around the problem, see Upgrading WebSphere Process Server test environment to V7.0.0.3 for WebSphere Integration Developer.
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Document Information
Modified date:
15 June 2018
UID
swg21447631