Troubleshooting
Problem
Customer is trying to change the TM1 server authentication option from 'Native' to 'Cognos 8' (CAM security). Administrator is clicks "Security - Clients/Groups - Add New Client". This does not work.
Symptom
Different symptoms appear (after selecting "Security - Clients/Groups Add New Client) depending on the value of "IntegratedSecurityMode":
- When IntegratedSecurityMode=2: nothing happens
- When IntegratedSecurityMode=5: user receives error message "Unable to create CAM client object"
Cause
Missing file (tm1camclient.dll) on TM1 client.
More Information:
There are many potential causes for this missing file, but in one real-life example the end user had installed ONLY "TM1 Architect" (on the client computer).
- When installing the full TM1 client, the following required files are installed on the "...TM1\bin" client directory: tm1camclient.dll, C8ITKProxy.dll and C8ITKShared.dll
- If you ONLY install "Architect" then "tm1camclient.dll" will not be installed
Environment
Resolving The Problem
Fix:
Install the full TM1 client.
Workaround:
Copy the file "tm1camclient.dll" (from another installation) onto the client device.
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Document Information
Modified date:
15 June 2018
UID
swg21445231