Troubleshooting
Problem
Attempts to install IBM Rational Directory Server (RDS) results in the error "Directory Server port not available. Please choose another free port".
Symptom
While installing Rational Directory Server, you see one of the following errors:
Directory Server port not available. Please choose another free port
or
Directory Server port is not available. Please choose another free port
Cause
Some reasons for this error are as follows:
- There is already a process listening on that port.
- The ports you set for RDS are set in the file /etc/services or the services NIS map used by the OS.
- The host is not properly defined in the /etc/hosts file
- You have run into defect APAR PM05591.
Environment
Resolving The Problem
Match the corresponding solution to the cause above:
- There is already a process listening on that port.
Run the following command from a command prompt:
netstat -na | grep "LISTEN"
If there is a process listening on that port, you must select another one for RDS or choose another one for the other application.
- The ports you set for RDS are set in the file /etc/services or the services NIS map used by the OS.
- Edit the file /etc/services or the NIS service file
- Look for any entry using the port number you want to use for RDS. Delete the conflicting entry and save the change.
- Look also for any entry having the same digits in the same order as the port number you want to use for RDS. Then delete the entry and save the change.
For example, if you want to use the port number 1234 for RDS, and you have an entry "XXX 12345/tcp", delete that line too in the /etc/services.
- The host is not properly defined in the /etc/hosts file
If the "localhost" is not defined in the /etc/hosts file you need to add it.
For example, if you have the following lines in the /etc/hosts file:
127.0.0.1 localhost.localdomain
192.168.0.1 toto
Where toto is the name of your machine.
Then change that that file as followed:
127.0.0.1 localhost.localdomain localhost
192.168.0.1 toto
- APAR PM05591: Install Script needs to be edited to allow successful installation to proceed
This defect relates to the install script "rds_install.sh" and "checkPortFree" function.
This issue was resolved in RDS release 5.1.1 and later.
Once you have made the appropriate change try to install RDS again.
[{"Product":{"code":"SS4AKG","label":"Rational Directory Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"5.0;5.1;5.1.1;5.2","Edition":"","Line of Business":{"code":"LOB15","label":"Integration"}},{"Product":{"code":"SSYQQ2","label":"Rational Change"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Directory Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"5.1;5.2;5.2.0.2","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Directory Server","Platform":[{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.1;9.1.0.2;9.2;9.2.0.1;9.2.0.2;9.2.0.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSC6Q5","label":"Rational Synergy"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Directory Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF010","label":"HP-UX"}],"Version":"7.1a;7.1.0.2;7.1.0.1;7.1;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
22 December 2020
UID
swg21444212